acess denied after installation, IIS 5.1

Topics: Tackle Installation
Sep 25, 2007 at 7:23 PM
I'm having acess denied problems. I just installed Tackle following the instructions. The step on Starting Tackle says that if you get an Access Denied message there is one last step to complete which is adding the IIS_WPG group to the tackle folder permissions.

Unless I'm mistaken the IIS_WPG group was added in IIS 6.0, but since I am using IIS 5.1 I do not have that group. How do I complete the installation?

(actually I get the access deined message from clicking "Product Backlog Entry". The Master Blacklog from the Products menu is not accessable to me)
Coordinator
Sep 25, 2007 at 7:47 PM
Is it an access denied message from within tackle or from your browser?
Sep 25, 2007 at 8:01 PM
from the browser.

I just installed the master page update, and it says the user I am using has read only rights.

I think in the installation of Tackle I missed specifying the administartor and am trying to figure that out now.


seanjenkin wrote:
Is it an access denied message from within tackle or from your browser?


Sep 27, 2007 at 3:00 PM
Edited Sep 27, 2007 at 6:45 PM
I am having the same problem. After installing the master page updates it seemed I was still logging in as anonymous as the main page said:
welcome: as read only

after forcing iis to use my login credentials by adding into the web.config <system.web> section:

<authorization>
<deny users="?" />
<authorization>

Now I see Welcome lcarnahan-admin as Read Only.
I can't get to any of the admin or setup functions though I can get to some pages in the menus...

This user is an admin on the machine and also has sysadmin privileges in the db...

OK, I tried adding my account to the tblUsers table as user #3 with privileges #1 (admin) this didn't work - although it may have been because I specified my domain i.e. engineering\lcarnahan

Finally I just went back and uninstalled everything and upon install put my domain-less alias in the admin alias entry in the db setup. i.e. lcarnahan

This yielded a database that had user #1 in the tblUsers with my alias lcarnahan in it and I was able to access everything but the master backlog page.

That turned out to be a .net access problem that I was able to debug from the web page errors.

It's all working now. Phew!
Sep 27, 2007 at 7:59 PM
Hi, I've installed Tackle on my notebook running Win XP Pro, IIS 5.1, .NET framework 2.0 and SQLServer Express 2005.

When I go to http://localhost/Tackle I must authenticate with a user/password, what should i put there? Which user and password? I can't get Tackle to work!! All menu items are disabled under Administration/Product, etc
Sep 28, 2007 at 1:40 PM
I'm using a login that has local admin privileges, I'm not sure that is strictly necessary...

I found that the tblUsers first entry should have your login name and NOT "admin". You can do this be editing it, or if you do the install properly and give your login name (without domain) in the db setup page under "alias" it will fill it in for you during install.

Then if you've set up the directory permissions properly, and the IIS permissions properly it should work.

It took me a while to get it working, so keep trying!