This project is read-only.

Access Denied

Topics: Tackle Installation
Aug 14, 2007 at 5:42 PM
When I go to the tackle home page in a new install, I see:

Access denied. You do not have permission to access this site. Please email the site administrators at cstuntz to request access.

"cstuntz" is my Windows username. I'm running XP Pro on a domain. I entered "cstuntz" (without quotes) as the "alias" when I installed.

I've tried modifying tblUsers to other values like "Administrator" and vertex.cstuntz (vertex is my domain), but I still can't log in, and the message never changes. I reset IIS after each change to the DB.

Aug 14, 2007 at 5:53 PM
Go into IIS Manager and check that anonymous access is turned off and windows authentication is turned on.

The tblUsers should just have cstuntz as the entry. No domain needed.

Aug 14, 2007 at 7:56 PM
Thanks for your reply. I changed tblUsers back to its original username (cstuntz, the same as I originally installed) and turned off anonymous access (which was on).

Now the first thing that happens when I connect to http://localhost/tackle/ is this:

Development Error. You have found a bug in the Tackle site. Please email the site administrators at and supply a description of the action you were taking and the URL you were trying to reach. Please also copy and paste the text from below into the email. Thanks!

ErrorCode: 80131904
ErrorNumber 18452: Login failed for user 'TackleUser'. The user is not associated with a trusted SQL Server connection.
at System.Data.SqlClient.SqlInternalConnection.OnError(SqlException exception, Boolean breakConnection)
at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj)
at System.Data.SqlClient.TdsParser.Run(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj)
at System.Data.SqlClient.SqlInternalConnectionTds.CompleteLogin(Boolean enlistOK)
at System.Data.SqlClient.SqlInternalConnectionTds.AttemptOneLogin(ServerInfo serverInfo, String newPassword, Boolean ignoreSniOpenTimeout, Int64 timerExpire, SqlConnection owningObject)
at System.Data.SqlClient.SqlInternalConnectionTds.LoginNoFailover(String host, String newPassword, Boolean redirectedUserInstance, SqlConnection owningObject, SqlConnectionString connectionOptions, Int64 timerStart)
at System.Data.SqlClient.SqlInternalConnectionTds.OpenLoginEnlist(SqlConnection owningObject, SqlConnectionString connectionOptions, String newPassword, Boolean redirectedUserInstance)
at System.Data.SqlClient.SqlInternalConnectionTds..ctor(DbConnectionPoolIdentity identity, SqlConnectionString connectionOptions, Object providerInfo, String newPassword, SqlConnection owningObject, Boolean redirectedUserInstance)
at System.Data.SqlClient.SqlConnectionFactory.CreateConnection(DbConnectionOptions options, Object poolGroupProviderInfo, DbConnectionPool pool, DbConnection owningConnection)
at System.Data.ProviderBase.DbConnectionFactory.CreatePooledConnection(DbConnection owningConnection, DbConnectionPool pool, DbConnectionOptions options)
at System.Data.ProviderBase.DbConnectionPool.CreateObject(DbConnection owningObject)
at System.Data.ProviderBase.DbConnectionPool.UserCreateRequest(DbConnection owningObject)
at System.Data.ProviderBase.DbConnectionPool.GetConnection(DbConnection owningObject)
at System.Data.ProviderBase.DbConnectionFactory.GetConnection(DbConnection owningConnection)
at System.Data.ProviderBase.DbConnectionClosed.OpenConnection(DbConnection outerConnection, DbConnectionFactory connectionFactory)
at System.Data.SqlClient.SqlConnection.Open()
at TackleUtility.CallStoredProc(String SProc, SqlParameter[] sqlParams, GridView gv, SProcReturnValue spRetVal)

If I try to connect to http://localhost/tackle/ again I see the first message I described:

Access denied. You do not have permission to access this site. Please email the site administrators at cstuntz to request access.

I'm using SQL Server 2005 Express, if it matters. The docs indicate this version should work.
Aug 15, 2007 at 7:45 PM
Sounds like SQL Logins are not enabled on your install of SQL.

Go into SQL Management Studio and log on to your db.
Right-click the server and select properties
Go into Security
Find Sql Server and windows authentication mode and make sure its selected.

Click ok and try logging in from the web page again.
Aug 16, 2007 at 2:41 PM
OK. Management Studio didn't seem to come with Express, but I found a download here:

The server was set to Windows authentication. I got the server with VS 2005 and haven't used it before. I changed it as you suggest. The app indicated I had to restart the server, so I did.

Now Tackle appears to work (at least the home page does!).

Thanks very much for your help. I hope the information here helps to improve the install experience.